Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Sawicki2011-05-11 20:59:05 -0400
committerKevin Sawicki2011-05-11 20:59:05 -0400
commit0d93fc473545becca69c0595289ac472afaea68f (patch)
treed13058e842837a7feb2375cb0a48c798976570ae /org.eclipse.egit.github.core.tests/META-INF/MANIFEST.MF
parent31e119034516c7674964a6c7c87fedefd57376b8 (diff)
downloadegit-github-0d93fc473545becca69c0595289ac472afaea68f.tar.gz
egit-github-0d93fc473545becca69c0595289ac472afaea68f.tar.xz
egit-github-0d93fc473545becca69c0595289ac472afaea68f.zip
Add new core GitHub API plug-in and unit tests.
This moves the current API unit tests from the mylyn test plug-in and creates a new package of live tests that can be run directly against a GitHub instance. The new core API plug-in has no Eclipse dependencies and only relies on GSON and Apache Commons HTTP client. Change-Id: I2b4dc436760818e5fcf1503f7ba80e351aca4fb6 Signed-off-by: Kevin Sawicki <kevin@github.com>
Diffstat (limited to 'org.eclipse.egit.github.core.tests/META-INF/MANIFEST.MF')
-rw-r--r--org.eclipse.egit.github.core.tests/META-INF/MANIFEST.MF18
1 files changed, 18 insertions, 0 deletions
diff --git a/org.eclipse.egit.github.core.tests/META-INF/MANIFEST.MF b/org.eclipse.egit.github.core.tests/META-INF/MANIFEST.MF
new file mode 100644
index 00000000..bc4e2aea
--- /dev/null
+++ b/org.eclipse.egit.github.core.tests/META-INF/MANIFEST.MF
@@ -0,0 +1,18 @@
+Manifest-Version: 1.0
+Bundle-ManifestVersion: 2
+Bundle-Name: %pluginName
+Bundle-SymbolicName: org.eclipse.egit.github.core.tests
+Bundle-Version: 0.1.0.qualifier
+Bundle-Localization: plugin
+Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Import-Package: com.google.gson;version="1.6.0",
+ com.google.gson.reflect;version="1.6.0",
+ org.apache.commons.httpclient;version="3.1.0",
+ org.mockito;version="1.8.4",
+ org.mockito.runners;version="1.8.4",
+ org.mockito.stubbing;version="1.8.4"
+Require-Bundle: org.eclipse.egit.github.core;bundle-version="0.1.0",
+ org.junit;bundle-version="4.8.1",
+ org.hamcrest;bundle-version="1.1.0",
+ org.objenesis;bundle-version="1.0.0"
+Bundle-Vendor: %providerName

Back to the top