Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Keppler2019-04-11 15:49:50 -0400
committerMichael Keppler2019-04-11 15:49:50 -0400
commit4d7e18676df64a4c63d5b0f5e8b4bd9a389f830d (patch)
treedc7943aed714756212b96d137335afce4a7aa839 /org.eclipse.egit.github.core.tests/.settings
parent8ce3cea959f2eda100436f9318d34528783fc73b (diff)
downloadegit-github-4d7e18676df64a4c63d5b0f5e8b4bd9a389f830d.tar.gz
egit-github-4d7e18676df64a4c63d5b0f5e8b4bd9a389f830d.tar.xz
egit-github-4d7e18676df64a4c63d5b0f5e8b4bd9a389f830d.zip
silence PDE warning "not all packages exported"
Since 2019-03 PDE shows a warning in each plugin which does not export all its packages. Let us silence this warning in all test bundles. Also add one missing package import (with restriction as internal). Change-Id: Ibeb28bdd78486d4048a11e516280ed2e78ab303d Signed-off-by: Michael Keppler <Michael.Keppler@gmx.de>
Diffstat (limited to 'org.eclipse.egit.github.core.tests/.settings')
-rw-r--r--org.eclipse.egit.github.core.tests/.settings/org.eclipse.pde.prefs34
1 files changed, 34 insertions, 0 deletions
diff --git a/org.eclipse.egit.github.core.tests/.settings/org.eclipse.pde.prefs b/org.eclipse.egit.github.core.tests/.settings/org.eclipse.pde.prefs
new file mode 100644
index 00000000..2174e4fd
--- /dev/null
+++ b/org.eclipse.egit.github.core.tests/.settings/org.eclipse.pde.prefs
@@ -0,0 +1,34 @@
+compilers.f.unresolved-features=1
+compilers.f.unresolved-plugins=1
+compilers.incompatible-environment=1
+compilers.p.build=1
+compilers.p.build.bin.includes=1
+compilers.p.build.encodings=2
+compilers.p.build.java.compiler=2
+compilers.p.build.java.compliance=1
+compilers.p.build.missing.output=2
+compilers.p.build.output.library=1
+compilers.p.build.source.library=1
+compilers.p.build.src.includes=1
+compilers.p.deprecated=1
+compilers.p.discouraged-class=1
+compilers.p.internal=1
+compilers.p.missing-packages=2
+compilers.p.missing-version-export-package=2
+compilers.p.missing-version-import-package=2
+compilers.p.missing-version-require-bundle=2
+compilers.p.no-required-att=0
+compilers.p.no.automatic.module=1
+compilers.p.not-externalized-att=2
+compilers.p.service.component.without.lazyactivation=1
+compilers.p.unknown-attribute=1
+compilers.p.unknown-class=1
+compilers.p.unknown-element=1
+compilers.p.unknown-identifier=1
+compilers.p.unknown-resource=1
+compilers.p.unresolved-ex-points=0
+compilers.p.unresolved-import=0
+compilers.s.create-docs=false
+compilers.s.doc-folder=doc
+compilers.s.open-tags=1
+eclipse.preferences.version=1

Back to the top