Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Keppler2019-03-08 09:13:10 -0500
committerMichael Keppler2019-03-08 09:13:10 -0500
commit512f7a8d5812cf70c7592d41d839714dc59a021d (patch)
tree8e1b622dfd401429168d8b075f346b0e9717d7c4
parentac7688017ffeb5b0e2fe34a8ec9483b80a7bfeb9 (diff)
downloadegit-github-512f7a8d5812cf70c7592d41d839714dc59a021d.tar.gz
egit-github-512f7a8d5812cf70c7592d41d839714dc59a021d.tar.xz
egit-github-512f7a8d5812cf70c7592d41d839714dc59a021d.zip
Require Mylyn 3.21 (Neon+)
The oldest tested target platform in egit (egit-4.6.target) contains Mylyn 3.21.0. We should therefore require at least that version as dependency both in the egit/egit-github plugins and features. All changes have been done by matching the current version of each bundle from the target platform in the manifest editor. I.e. this was no search and replace. Change-Id: I6b33256fbb381563226a6374d2d968b2e0e62bdc Signed-off-by: Michael Keppler <Michael.Keppler@gmx.de>
-rw-r--r--org.eclipse.mylyn.github-feature/feature.xml2
-rw-r--r--org.eclipse.mylyn.github.core/META-INF/MANIFEST.MF4
-rw-r--r--org.eclipse.mylyn.github.tests/META-INF/MANIFEST.MF2
-rw-r--r--org.eclipse.mylyn.github.ui/META-INF/MANIFEST.MF18
4 files changed, 13 insertions, 13 deletions
diff --git a/org.eclipse.mylyn.github-feature/feature.xml b/org.eclipse.mylyn.github-feature/feature.xml
index e4afc2e8..104524f7 100644
--- a/org.eclipse.mylyn.github-feature/feature.xml
+++ b/org.eclipse.mylyn.github-feature/feature.xml
@@ -22,7 +22,7 @@
<requires>
<import feature="org.eclipse.egit" version="5.4.0" match="equivalent"/>
- <import feature="org.eclipse.mylyn_feature" version="3.9.0" match="greaterOrEqual"/>
+ <import feature="org.eclipse.mylyn_feature" version="3.21.0" match="greaterOrEqual"/>
<import plugin="com.google.gson" version="1.6" match="greaterOrEqual"/>
</requires>
diff --git a/org.eclipse.mylyn.github.core/META-INF/MANIFEST.MF b/org.eclipse.mylyn.github.core/META-INF/MANIFEST.MF
index 88ee25c9..a89240d5 100644
--- a/org.eclipse.mylyn.github.core/META-INF/MANIFEST.MF
+++ b/org.eclipse.mylyn.github.core/META-INF/MANIFEST.MF
@@ -12,8 +12,8 @@ Export-Package: org.eclipse.mylyn.internal.github.core;version="5.4.0";x-friends
org.eclipse.mylyn.internal.github.core.issue;version="5.4.0";x-friends:="org.eclipse.mylyn.github.ui",
org.eclipse.mylyn.internal.github.core.pr;version="5.4.0";x-friends:="org.eclipse.mylyn.github.ui"
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
- org.eclipse.mylyn.tasks.core;bundle-version="[3.4.0,4.0.0)",
- org.eclipse.mylyn.commons.net;bundle-version="[3.4.0,4.0.0)"
+ org.eclipse.mylyn.tasks.core;bundle-version="[3.21.0,4.0.0)",
+ org.eclipse.mylyn.commons.net;bundle-version="[3.21.0,4.0.0)"
Import-Package: org.eclipse.egit.core;version="[5.4.0,5.5.0)",
org.eclipse.egit.github.core;version="[5.4.0,5.5.0)",
org.eclipse.egit.github.core.client;version="[5.4.0,5.5.0)",
diff --git a/org.eclipse.mylyn.github.tests/META-INF/MANIFEST.MF b/org.eclipse.mylyn.github.tests/META-INF/MANIFEST.MF
index a4e41418..5511e23f 100644
--- a/org.eclipse.mylyn.github.tests/META-INF/MANIFEST.MF
+++ b/org.eclipse.mylyn.github.tests/META-INF/MANIFEST.MF
@@ -6,7 +6,7 @@ Bundle-SymbolicName: org.eclipse.mylyn.github.tests
Bundle-Version: 5.4.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Require-Bundle: org.eclipse.jface.text;bundle-version="[3.4.0,4.0.0)",
- org.eclipse.mylyn.tasks.core;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.mylyn.tasks.core;bundle-version="[3.21.0,4.0.0)",
org.junit;bundle-version="[4.12.0,5.0.0)"
Bundle-Vendor: Eclipse EGit
Import-Package: org.eclipse.mylyn.internal.github.core;version="[5.4.0,5.5.0)",
diff --git a/org.eclipse.mylyn.github.ui/META-INF/MANIFEST.MF b/org.eclipse.mylyn.github.ui/META-INF/MANIFEST.MF
index fe44a1ee..f1fb1e66 100644
--- a/org.eclipse.mylyn.github.ui/META-INF/MANIFEST.MF
+++ b/org.eclipse.mylyn.github.ui/META-INF/MANIFEST.MF
@@ -11,19 +11,19 @@ Bundle-Localization: plugin
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.ui;bundle-version="[3.5.0,4.0.0)",
org.eclipse.ui.forms;bundle-version="[3.4.0,4.0.0)",
- org.eclipse.mylyn.tasks.ui;bundle-version="[3.9.0,4.0.0)",
+ org.eclipse.mylyn.tasks.ui;bundle-version="[3.21.0,4.0.0)",
org.eclipse.jface.text;bundle-version="[3.5.0,4.0.0)",
- org.eclipse.mylyn.commons.core;bundle-version="[3.9.0,4.0.0)",
- org.eclipse.mylyn.commons.workbench;bundle-version="[3.9.0,4.0.0)",
- org.eclipse.mylyn.commons.net;bundle-version="[3.9.0,4.0.0)",
- org.eclipse.mylyn.tasks.core;bundle-version="[3.9.0,4.0.0)",
+ org.eclipse.mylyn.commons.core;bundle-version="[3.21.0,4.0.0)",
+ org.eclipse.mylyn.commons.workbench;bundle-version="[3.21.0,4.0.0)",
+ org.eclipse.mylyn.commons.net;bundle-version="[3.21.0,4.0.0)",
+ org.eclipse.mylyn.tasks.core;bundle-version="[3.21.0,4.0.0)",
org.eclipse.ui.ide;bundle-version="[3.5.0,4.0.0)",
- org.eclipse.mylyn.commons.ui;bundle-version="[3.9.0,4.0.0)",
+ org.eclipse.mylyn.commons.ui;bundle-version="[3.21.0,4.0.0)",
org.eclipse.core.resources;bundle-version="[3.5.0,4.0.0)",
org.eclipse.core.expressions;bundle-version="[3.4.0,4.0.0)",
- org.eclipse.mylyn.context.core;bundle-version="[3.9.0,4.0.0)",
- org.eclipse.mylyn.monitor.core;bundle-version="[3.9.0,4.0.0)",
- org.eclipse.mylyn.resources.ui;bundle-version="[3.9.0,4.0.0)"
+ org.eclipse.mylyn.context.core;bundle-version="[3.21.0,4.0.0)",
+ org.eclipse.mylyn.monitor.core;bundle-version="[3.21.0,4.0.0)",
+ org.eclipse.mylyn.resources.ui;bundle-version="[3.21.0,4.0.0)"
Export-Package: org.eclipse.mylyn.internal.github.ui;version="5.4.0";x-internal:=true,
org.eclipse.mylyn.internal.github.ui.gist;version="5.4.0";x-internal:=true,
org.eclipse.mylyn.internal.github.ui.issue;version="5.4.0";x-internal:=true

Back to the top