Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Sohn2011-06-17 18:07:07 -0400
committerMatthias Sohn2011-06-17 18:47:55 -0400
commit2e34ed10d4cf041062a3ac95592c5d698cf14aa1 (patch)
tree41193a49ce09296a676875b3d27ce25fa1c021ef
parent5d946bd5ed0c37880f2945f770dac03331b59f2e (diff)
downloadegit-github-2e34ed10d4cf041062a3ac95592c5d698cf14aa1.tar.gz
egit-github-2e34ed10d4cf041062a3ac95592c5d698cf14aa1.tar.xz
egit-github-2e34ed10d4cf041062a3ac95592c5d698cf14aa1.zip
Fix dependencies to use proper version ranges
This enables running the bundles across platform versions starting from Eclipse 3.5. Change-Id: I4781244581d4093f8c8b31d88de790f19d59a9a0 Signed-off-by: Matthias Sohn <matthias.sohn@sap.com>
-rw-r--r--org.eclipse.egit.github.core.tests/META-INF/MANIFEST.MF20
-rw-r--r--org.eclipse.egit.github.core/META-INF/MANIFEST.MF34
-rw-r--r--org.eclipse.mylyn.github.tests/META-INF/MANIFEST.MF22
3 files changed, 38 insertions, 38 deletions
diff --git a/org.eclipse.egit.github.core.tests/META-INF/MANIFEST.MF b/org.eclipse.egit.github.core.tests/META-INF/MANIFEST.MF
index c7471817..c9c9b9d0 100644
--- a/org.eclipse.egit.github.core.tests/META-INF/MANIFEST.MF
+++ b/org.eclipse.egit.github.core.tests/META-INF/MANIFEST.MF
@@ -5,14 +5,14 @@ Bundle-SymbolicName: org.eclipse.egit.github.core.tests
Bundle-Version: 1.0.0.qualifier
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Import-Package: com.google.gson;version="1.6.0",
- com.google.gson.reflect;version="1.6.0",
- org.apache.http;version="4.1.0",
- org.mockito;version="1.8.4",
- org.mockito.runners;version="1.8.4",
- org.mockito.stubbing;version="1.8.4"
-Require-Bundle: org.eclipse.egit.github.core;bundle-version="0.1.0",
- org.junit;bundle-version="4.8.1",
- org.hamcrest;bundle-version="1.1.0",
- org.objenesis;bundle-version="1.0.0"
+Import-Package: com.google.gson;version="[1.6.0,2.0.0)",
+ com.google.gson.reflect;version="[1.6.0,2.0.0)",
+ org.apache.http;version="[4.1.0,5.0.0)",
+ org.mockito;version="[1.8.4,2.0.0)",
+ org.mockito.runners;version="[1.8.4,2.0.0)",
+ org.mockito.stubbing;version="[1.8.4,2.0.0)"
+Require-Bundle: org.eclipse.egit.github.core;bundle-version="[1.0.0,1.1.0)",
+ org.junit;bundle-version="[4.8.1,5.0.0)",
+ org.hamcrest;bundle-version="[1.1.0,2.0.0)",
+ org.objenesis;bundle-version="[1.0.0,2.0.0)"
Bundle-Vendor: %providerName
diff --git a/org.eclipse.egit.github.core/META-INF/MANIFEST.MF b/org.eclipse.egit.github.core/META-INF/MANIFEST.MF
index 39b6baa5..995f2ea5 100644
--- a/org.eclipse.egit.github.core/META-INF/MANIFEST.MF
+++ b/org.eclipse.egit.github.core/META-INF/MANIFEST.MF
@@ -6,23 +6,23 @@ Bundle-SymbolicName: org.eclipse.egit.github.core
Bundle-Version: 1.0.0.qualifier
Bundle-Vendor: %providerName
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Import-Package: com.google.gson;version="1.6.0",
- com.google.gson.annotations;version="1.6.0",
- com.google.gson.reflect;version="1.6.0",
- org.apache.http;version="4.1.0",
- org.apache.http.auth;version="4.1.0",
- org.apache.http.client;version="4.1.0",
- org.apache.http.client.methods;version="4.1.0",
- org.apache.http.client.protocol;version="4.1.0",
- org.apache.http.client.utils;version="4.1.0",
- org.apache.http.conn;version="4.1.0",
- org.apache.http.conn.routing;version="4.1.0",
- org.apache.http.entity;version="4.1.0",
- org.apache.http.impl.auth;version="4.1.0",
- org.apache.http.impl.client;version="4.1.0",
- org.apache.http.impl.conn;version="4.1.0",
- org.apache.http.message;version="4.1.0",
- org.apache.http.protocol;version="4.1.0"
+Import-Package: com.google.gson;version="[1.6.0,2.0.0)",
+ com.google.gson.annotations;version="[1.6.0,2.0.0)",
+ com.google.gson.reflect;version="[1.6.0,2.0.0)",
+ org.apache.http;version="[4.1.0,5.0.0)",
+ org.apache.http.auth;version="[4.1.0,5.0.0)",
+ org.apache.http.client;version="[4.1.0,5.0.0)",
+ org.apache.http.client.methods;version="[4.1.0,5.0.0)",
+ org.apache.http.client.protocol;version="[4.1.0,5.0.0)",
+ org.apache.http.client.utils;version="[4.1.0,5.0.0)",
+ org.apache.http.conn;version="[4.1.0,5.0.0)",
+ org.apache.http.conn.routing;version="[4.1.0,5.0.0)",
+ org.apache.http.entity;version="[4.1.0,5.0.0)",
+ org.apache.http.impl.auth;version="[4.1.0,5.0.0)",
+ org.apache.http.impl.client;version="[4.1.0,5.0.0)",
+ org.apache.http.impl.conn;version="[4.1.0,5.0.0)",
+ org.apache.http.message;version="[4.1.0,5.0.0)",
+ org.apache.http.protocol;version="[4.1.0,5.0.0)"
Export-Package: org.eclipse.egit.github.core,
org.eclipse.egit.github.core.client,
org.eclipse.egit.github.core.service,
diff --git a/org.eclipse.mylyn.github.tests/META-INF/MANIFEST.MF b/org.eclipse.mylyn.github.tests/META-INF/MANIFEST.MF
index b5d4df90..b6fd96dd 100644
--- a/org.eclipse.mylyn.github.tests/META-INF/MANIFEST.MF
+++ b/org.eclipse.mylyn.github.tests/META-INF/MANIFEST.MF
@@ -4,16 +4,16 @@ Bundle-Name: Eclipse EGit Mylyn GitHub Tests
Bundle-SymbolicName: org.eclipse.mylyn.github.tests
Bundle-Version: 1.0.0.qualifier
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Require-Bundle: org.eclipse.mylyn.github.core;bundle-version="1.0.0",
- org.eclipse.mylyn.github.ui;bundle-version="1.0.0",
- org.eclipse.jface.text;bundle-version="3.5.0",
- org.eclipse.mylyn.tasks.ui;bundle-version="3.2.0",
+Require-Bundle: org.eclipse.mylyn.github.core;bundle-version="[1.0.0,1.1.0)",
+ org.eclipse.mylyn.github.ui;bundle-version="[1.0.0,1.1.0)",
+ org.eclipse.jface.text;bundle-version="[3.5.0,4.0.0)",
+ org.eclipse.mylyn.tasks.ui;bundle-version="[3.2.0,4.0.0)",
org.eclipse.mylyn.tasks.core,
- org.eclipse.core.runtime;bundle-version="3.5.0",
- org.junit;bundle-version="4.8.1",
- org.hamcrest;bundle-version="1.1.0",
- org.objenesis;bundle-version="1.0.0"
+ org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
+ org.junit;bundle-version="[4.8.1,5.0.0)",
+ org.hamcrest;bundle-version="[1.1.0,2.0.0)",
+ org.objenesis;bundle-version="[1.0.0,2.0.0)"
Bundle-Vendor: Eclipse EGit
-Import-Package: org.mockito;version="1.8.4",
- org.mockito.runners;version="1.8.4",
- org.mockito.stubbing;version="1.8.4"
+Import-Package: org.mockito;version="[1.8.4,2.0.0)",
+ org.mockito.runners;version="[1.8.4,2.0.0)",
+ org.mockito.stubbing;version="[1.8.4,2.0.0)"

Back to the top