Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to 'providers/bundles/org.eclipse.ecf.provider.r_osgi/META-INF/MANIFEST.MF')
-rw-r--r--providers/bundles/org.eclipse.ecf.provider.r_osgi/META-INF/MANIFEST.MF20
1 files changed, 10 insertions, 10 deletions
diff --git a/providers/bundles/org.eclipse.ecf.provider.r_osgi/META-INF/MANIFEST.MF b/providers/bundles/org.eclipse.ecf.provider.r_osgi/META-INF/MANIFEST.MF
index 6deb2e94c..a6a3ab8e9 100644
--- a/providers/bundles/org.eclipse.ecf.provider.r_osgi/META-INF/MANIFEST.MF
+++ b/providers/bundles/org.eclipse.ecf.provider.r_osgi/META-INF/MANIFEST.MF
@@ -4,17 +4,17 @@ Bundle-Name: %plugin.name
Bundle-SymbolicName: org.eclipse.ecf.provider.r_osgi;singleton:=true
Automatic-Module-Name: org.eclipse.ecf.provider.r_osgi
Bundle-Version: 3.5.700.qualifier
-Import-Package: ch.ethz.iks.r_osgi;version="1.0.1",
+Import-Package: ch.ethz.iks.r_osgi;version="[1.0.1,2.0.0)",
org.eclipse.ecf.core.util.reflection,
- org.eclipse.ecf.remoteservice.asyncproxy;version="1.0.0",
- org.eclipse.equinox.concurrent.future;version="1.0.0",
- org.osgi.framework;version="1.3.0",
- org.osgi.framework.wiring,
- org.osgi.util.tracker;version="1.3.3"
-Require-Bundle: org.eclipse.ecf;bundle-version="3.1.0",
- org.eclipse.ecf.provider,
- org.eclipse.ecf.remoteservice;bundle-version="5.0.0",
- org.eclipse.equinox.common
+ org.eclipse.ecf.remoteservice.asyncproxy;version="[1.0.0,3.0.0)",
+ org.eclipse.equinox.concurrent.future;version="[1.0.0,2.0.0)",
+ org.osgi.framework;version="[1.3.0,2.0.0)",
+ org.osgi.framework.wiring;version="[1.2.0,3.0.0)",
+ org.osgi.util.tracker;version="[1.3.3,2.0.0)"
+Require-Bundle: org.eclipse.ecf;bundle-version="[3.1.0,4.0.0)",
+ org.eclipse.ecf.provider;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.ecf.remoteservice;bundle-version="[8.0.0,10.0.0)",
+ org.eclipse.equinox.common;bundle-version="[3.0.0,4.0.0)"
Bundle-Activator: org.eclipse.ecf.internal.provider.r_osgi.Activator
Eclipse-LazyStart: true
Export-Package: org.eclipse.ecf.provider.r_osgi.identity;version="3.2.0"

Back to the top