Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorslewis2014-01-24 02:00:45 -0500
committerslewis2014-01-24 02:00:45 -0500
commit54ecca0903de279f91eb1f6b294a49d3c5d2f96f (patch)
treee3e705612f6f4681e1f08c262c65863a16ff01ae /incubation
parent0f9437b178c2b41bd21c7eda7fb4dc35a0e9fa77 (diff)
downloadorg.eclipse.ecf-54ecca0903de279f91eb1f6b294a49d3c5d2f96f.tar.gz
org.eclipse.ecf-54ecca0903de279f91eb1f6b294a49d3c5d2f96f.tar.xz
org.eclipse.ecf-54ecca0903de279f91eb1f6b294a49d3c5d2f96f.zip
Added Require-Capability for osgi.extender namespace in bundles with
EDEF files (tests, examples) as specified in section 5.5.1 of RFC 203. Change-Id: Id5e8f10f16ab48ec5bf30bb82a3fdce66115615b
Diffstat (limited to 'incubation')
-rw-r--r--incubation/bundles/org.eclipse.ecf.provider.endpointdescription.localdiscovery/META-INF/MANIFEST.MF3
1 files changed, 2 insertions, 1 deletions
diff --git a/incubation/bundles/org.eclipse.ecf.provider.endpointdescription.localdiscovery/META-INF/MANIFEST.MF b/incubation/bundles/org.eclipse.ecf.provider.endpointdescription.localdiscovery/META-INF/MANIFEST.MF
index 6e41c806f..9b88bb6c3 100644
--- a/incubation/bundles/org.eclipse.ecf.provider.endpointdescription.localdiscovery/META-INF/MANIFEST.MF
+++ b/incubation/bundles/org.eclipse.ecf.provider.endpointdescription.localdiscovery/META-INF/MANIFEST.MF
@@ -3,7 +3,7 @@ Bundle-ManifestVersion: 2
Bundle-Name: %plugin.name
Bundle-Vendor: %plugin.provider
Bundle-SymbolicName: org.eclipse.ecf.provider.endpointdescription.localdiscovery;singleton:=true
-Bundle-Version: 1.0.0.qualifier
+Bundle-Version: 1.1.0.qualifier
Bundle-Activator: org.eclipse.ecf.provider.internal.endpointdescription.localdiscovery.Activator
Bundle-ActivationPolicy: lazy
Bundle-RequiredExecutionEnvironment: J2SE-1.5
@@ -20,3 +20,4 @@ Import-Package: org.eclipse.ecf.core;version="3.0.0",
org.osgi.util.tracker
Bundle-Localization: plugin
Require-Bundle: org.eclipse.equinox.common;bundle-version="3.6.0"
+Requre-Capability: osgi.extender; filter:=(&(osgi.extender=osgi.remoteserviceadmin) (version>=1.1)); effective:=active

Back to the top