Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormkuppe2009-02-12 08:57:05 -0500
committermkuppe2009-02-12 08:57:05 -0500
commit6b32b10945bb39443caf5447b5ed8cf14bf959cd (patch)
tree7fd4156bc375eb0fcc0d7fa0e4a99b98e46117ed /framework/bundles/org.eclipse.ecf.sync
parentc11ae9fdaee192df3ded75544354e444b0d1ee0d (diff)
downloadorg.eclipse.ecf-6b32b10945bb39443caf5447b5ed8cf14bf959cd.tar.gz
org.eclipse.ecf-6b32b10945bb39443caf5447b5ed8cf14bf959cd.tar.xz
org.eclipse.ecf-6b32b10945bb39443caf5447b5ed8cf14bf959cd.zip
NEW - bug 264126: BREE should include Foundation 1.1 as much as possible
https://bugs.eclipse.org/bugs/show_bug.cgi?id=264126
Diffstat (limited to 'framework/bundles/org.eclipse.ecf.sync')
-rw-r--r--framework/bundles/org.eclipse.ecf.sync/.classpath2
-rw-r--r--framework/bundles/org.eclipse.ecf.sync/.settings/org.eclipse.jdt.core.prefs7
-rw-r--r--framework/bundles/org.eclipse.ecf.sync/META-INF/MANIFEST.MF3
3 files changed, 9 insertions, 3 deletions
diff --git a/framework/bundles/org.eclipse.ecf.sync/.classpath b/framework/bundles/org.eclipse.ecf.sync/.classpath
index 2fbb7a23e..6f3b481ac 100644
--- a/framework/bundles/org.eclipse.ecf.sync/.classpath
+++ b/framework/bundles/org.eclipse.ecf.sync/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.4"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/CDC-1.1%Foundation-1.1"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/framework/bundles/org.eclipse.ecf.sync/.settings/org.eclipse.jdt.core.prefs b/framework/bundles/org.eclipse.ecf.sync/.settings/org.eclipse.jdt.core.prefs
index b41e35e93..7c8c37cd7 100644
--- a/framework/bundles/org.eclipse.ecf.sync/.settings/org.eclipse.jdt.core.prefs
+++ b/framework/bundles/org.eclipse.ecf.sync/.settings/org.eclipse.jdt.core.prefs
@@ -1,4 +1,4 @@
-#Tue Feb 03 17:14:09 PST 2009
+#Mon Feb 09 23:11:49 CET 2009
eclipse.preferences.version=1
org.eclipse.jdt.core.builder.cleanOutputFolder=clean
org.eclipse.jdt.core.builder.duplicateResourceTask=warning
@@ -8,8 +8,11 @@ org.eclipse.jdt.core.builder.resourceCopyExclusionFilter=*.launch
org.eclipse.jdt.core.circularClasspath=error
org.eclipse.jdt.core.classpath.exclusionPatterns=enabled
org.eclipse.jdt.core.classpath.multipleOutputLocations=enabled
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.2
+org.eclipse.jdt.core.compiler.compliance=1.4
org.eclipse.jdt.core.compiler.maxProblemPerUnit=100
org.eclipse.jdt.core.compiler.problem.annotationSuperInterface=warning
+org.eclipse.jdt.core.compiler.problem.assertIdentifier=warning
org.eclipse.jdt.core.compiler.problem.autoboxing=ignore
org.eclipse.jdt.core.compiler.problem.comparingIdentical=warning
org.eclipse.jdt.core.compiler.problem.deadCode=warning
@@ -18,6 +21,7 @@ org.eclipse.jdt.core.compiler.problem.deprecationInDeprecatedCode=disabled
org.eclipse.jdt.core.compiler.problem.deprecationWhenOverridingDeprecatedMethod=disabled
org.eclipse.jdt.core.compiler.problem.discouragedReference=warning
org.eclipse.jdt.core.compiler.problem.emptyStatement=ignore
+org.eclipse.jdt.core.compiler.problem.enumIdentifier=warning
org.eclipse.jdt.core.compiler.problem.fallthroughCase=ignore
org.eclipse.jdt.core.compiler.problem.fatalOptionalError=enabled
org.eclipse.jdt.core.compiler.problem.fieldHiding=ignore
@@ -71,5 +75,6 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
+org.eclipse.jdt.core.compiler.source=1.3
org.eclipse.jdt.core.incompatibleJDKLevel=ignore
org.eclipse.jdt.core.incompleteClasspath=error
diff --git a/framework/bundles/org.eclipse.ecf.sync/META-INF/MANIFEST.MF b/framework/bundles/org.eclipse.ecf.sync/META-INF/MANIFEST.MF
index 6e6498e16..11d3898c3 100644
--- a/framework/bundles/org.eclipse.ecf.sync/META-INF/MANIFEST.MF
+++ b/framework/bundles/org.eclipse.ecf.sync/META-INF/MANIFEST.MF
@@ -5,7 +5,8 @@ Bundle-SymbolicName: org.eclipse.ecf.sync
Bundle-Version: 1.0.0.qualifier
Bundle-Activator: org.eclipse.ecf.internal.sync.Activator
Bundle-Vendor: %plugin.provider
-Bundle-RequiredExecutionEnvironment: J2SE-1.4
+Bundle-RequiredExecutionEnvironment: CDC-1.1/Foundation-1.1,
+ J2SE-1.4
Import-Package: org.eclipse.core.runtime,
org.eclipse.ecf.core.identity,
org.eclipse.ecf.core.util,

Back to the top