Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorslewis2018-02-28 12:30:51 -0500
committerslewis2018-02-28 12:30:51 -0500
commit4b1b96a8dea63ae298bdf32aaf8be280871df803 (patch)
tree8327587186deb1b5ad69a9f47481ff59f45823c2
parent964a379ef82d056328813c4ce7bfe72d23917856 (diff)
downloadorg.eclipse.ecf-4b1b96a8dea63ae298bdf32aaf8be280871df803.tar.gz
org.eclipse.ecf-4b1b96a8dea63ae298bdf32aaf8be280871df803.tar.xz
org.eclipse.ecf-4b1b96a8dea63ae298bdf32aaf8be280871df803.zip
bug https://bugs.eclipse.org/bugs/show_bug.cgi?id=530952
Update to manifests for org.eclipse.ecf and org.eclipse.ecf.identity Change-Id: Ie5a63341b4bef340a0b75b9022ae7db2fd8f8997
-rw-r--r--framework/bundles/org.eclipse.ecf.identity/META-INF/MANIFEST.MF15
-rw-r--r--framework/bundles/org.eclipse.ecf/META-INF/MANIFEST.MF15
2 files changed, 16 insertions, 14 deletions
diff --git a/framework/bundles/org.eclipse.ecf.identity/META-INF/MANIFEST.MF b/framework/bundles/org.eclipse.ecf.identity/META-INF/MANIFEST.MF
index 3c871794f..ebb4eda44 100644
--- a/framework/bundles/org.eclipse.ecf.identity/META-INF/MANIFEST.MF
+++ b/framework/bundles/org.eclipse.ecf.identity/META-INF/MANIFEST.MF
@@ -2,20 +2,21 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %plugin.name
Bundle-SymbolicName: org.eclipse.ecf.identity;singleton:=true
+Automatic-Module-Name: org.eclipse.ecf.identity
Bundle-Version: 3.9.0.qualifier
Bundle-Activator: org.eclipse.ecf.internal.core.identity.Activator
Bundle-Localization: plugin
Bundle-Vendor: %plugin.provider
Eclipse-LazyStart: true
Export-Package: org.eclipse.ecf.core.identity;version="3.3.0",
- org.eclipse.ecf.core.util;version="3.4.0",
+ org.eclipse.ecf.core.util;version="3.6.0",
org.eclipse.ecf.internal.core.identity;version="3.2.0";x-internal:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Import-Package: org.eclipse.osgi.service.debug;version="1.0.0",
- org.osgi.framework;version="1.3.0",
- org.osgi.service.log;version="1.3.0",
- org.osgi.util.tracker;version="1.3.2"
-Require-Bundle: org.eclipse.equinox.common,
- org.eclipse.equinox.registry;resolution:=optional
+Import-Package: org.eclipse.osgi.service.debug;version="[1.0.0,2.0.0)",
+ org.osgi.framework;version="[1.3.0,2.0.0)",
+ org.osgi.service.log;version="[1.3.0,2.0.0)",
+ org.osgi.util.tracker;version="[1.3.2,2.0.0)"
+Require-Bundle: org.eclipse.equinox.common;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.equinox.registry;bundle-version="[3.0.0,4.0.0)";resolution:=optional
Bundle-ActivationPolicy: lazy; exclude:="org.eclipse.ecf.core.util"
Provide-Capability: ecf.namespace;names:List<String>=”org.eclipse.ecf.core.identity.StringID,org.eclipse.ecf.core.identity.GUID,org.eclipse.ecf.core.identity.LongID,org.eclipse.ecf.core.identity.URIID”; version:Version=3.3
diff --git a/framework/bundles/org.eclipse.ecf/META-INF/MANIFEST.MF b/framework/bundles/org.eclipse.ecf/META-INF/MANIFEST.MF
index b28f9fa24..99715200f 100644
--- a/framework/bundles/org.eclipse.ecf/META-INF/MANIFEST.MF
+++ b/framework/bundles/org.eclipse.ecf/META-INF/MANIFEST.MF
@@ -1,6 +1,7 @@
Manifest-Version: 1.0
Bundle-Name: %plugin.name
Bundle-SymbolicName: org.eclipse.ecf;singleton:=true
+Automatic-Module-Name: org.eclipse.ecf
Bundle-Version: 3.8.0.qualifier
Bundle-Activator: org.eclipse.ecf.internal.core.ECFPlugin
Bundle-Vendor: %plugin.provider
@@ -16,16 +17,16 @@ Export-Package: org.eclipse.ecf.core;version="3.0.0",
org.eclipse.ecf.core.start;version="3.1.0",
org.eclipse.ecf.core.status;version="1.1.0",
org.eclipse.ecf.core.user;version="3.1.0",
- org.eclipse.ecf.core.util;version="3.5.0",
+ org.eclipse.ecf.core.util;version="3.6.0",
org.eclipse.ecf.core.util.reflection;version="2.3.0",
org.eclipse.ecf.internal.core;x-internal:=true
Import-Package: org.eclipse.core.runtime.jobs,
- org.eclipse.equinox.concurrent.future;version="1.0.0";resolution:=optional;x-installation:=greedy,
- org.osgi.framework;version="1.3.0",
- org.osgi.service.log;version="1.3.0",
- org.osgi.util.tracker;version="1.3.2"
-Require-Bundle: org.eclipse.equinox.common,
- org.eclipse.equinox.registry;resolution:=optional,
+ org.eclipse.equinox.concurrent.future;version="[1.0.0,2.0.0)";x-installation:=greedy,
+ org.osgi.framework;version="[1.3.0,2.0.0)",
+ org.osgi.service.log;version="[1.3.0,2.0.0)",
+ org.osgi.util.tracker;version="[1.3.2,2.0.0)"
+Require-Bundle: org.eclipse.equinox.common;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.equinox.registry;bundle-version="[3.0.0,4.0.0)";resolution:=optional,
org.eclipse.ecf.identity;visibility:=reexport
Bundle-ActivationPolicy: lazy
Provide-Capability: ecf.containertype;names:List<String>="ecf.base"; version:Version=3.3

Back to the top