Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorslewis2012-05-03 15:19:45 -0400
committerslewis2012-05-03 15:19:45 -0400
commit39f90e4dfa8cf5229b1d79ca03bd21529b00fd50 (patch)
tree7fc7ed48c3ade8c6dd249a537409d13c9ee001d4
parentd6f6135b4aa307d3f461d7ea26e78343b5aebe72 (diff)
downloadorg.eclipse.ecf-39f90e4dfa8cf5229b1d79ca03bd21529b00fd50.tar.gz
org.eclipse.ecf-39f90e4dfa8cf5229b1d79ca03bd21529b00fd50.tar.xz
org.eclipse.ecf-39f90e4dfa8cf5229b1d79ca03bd21529b00fd50.zip
Fixes to refer to org.osgi.service.remoteserviceadmin (version 5.0)R-Release_HEAD-sdk_feature-71_2012-05-03_19-24-24
rather than ECF-specific org.eclipse.osgi.service.remoteserviceadmin plugin.
-rw-r--r--compendium/bundles/org.eclipse.ecf.osgi.services.distribution/META-INF/MANIFEST.MF4
-rw-r--r--incubation/bundles/org.eclipse.ecf.provider.endpointdescription.localdiscovery/META-INF/MANIFEST.MF4
-rw-r--r--osgi/bundles/org.eclipse.ecf.osgi.services.remoteserviceadmin/META-INF/MANIFEST.MF4
-rw-r--r--osgi/bundles/org.eclipse.osgi.services.remoteserviceadmin/META-INF/MANIFEST.MF2
-rw-r--r--tests/bundles/org.eclipse.ecf.tests.osgi.services.remoteserviceadmin/META-INF/MANIFEST.MF4
5 files changed, 9 insertions, 9 deletions
diff --git a/compendium/bundles/org.eclipse.ecf.osgi.services.distribution/META-INF/MANIFEST.MF b/compendium/bundles/org.eclipse.ecf.osgi.services.distribution/META-INF/MANIFEST.MF
index 1b753ebb9..3a6cffc67 100644
--- a/compendium/bundles/org.eclipse.ecf.osgi.services.distribution/META-INF/MANIFEST.MF
+++ b/compendium/bundles/org.eclipse.ecf.osgi.services.distribution/META-INF/MANIFEST.MF
@@ -11,11 +11,11 @@ Import-Package: org.eclipse.ecf.core.util,
org.osgi.framework;version="1.3.0",
org.osgi.framework.hooks.service;version="1.0.0",
org.osgi.service.log;version="1.3.0",
+ org.osgi.service.remoteserviceadmin;version="5.0.0",
org.osgi.util.tracker
Bundle-ActivationPolicy: lazy
Bundle-Localization: plugin
Export-Package: org.eclipse.ecf.internal.osgi.services.distribution;version="2.0.0";x-internal:=true,
org.eclipse.ecf.osgi.services.distribution;version="2.0.0";x-internal:=true
Require-Bundle: org.eclipse.equinox.common,
- org.eclipse.ecf.osgi.services.remoteserviceadmin;bundle-version="1.0.0",
- org.eclipse.osgi.services.remoteserviceadmin;bundle-version="1.5.0"
+ org.eclipse.ecf.osgi.services.remoteserviceadmin;bundle-version="1.0.0"
diff --git a/incubation/bundles/org.eclipse.ecf.provider.endpointdescription.localdiscovery/META-INF/MANIFEST.MF b/incubation/bundles/org.eclipse.ecf.provider.endpointdescription.localdiscovery/META-INF/MANIFEST.MF
index de345e332..9e551a301 100644
--- a/incubation/bundles/org.eclipse.ecf.provider.endpointdescription.localdiscovery/META-INF/MANIFEST.MF
+++ b/incubation/bundles/org.eclipse.ecf.provider.endpointdescription.localdiscovery/META-INF/MANIFEST.MF
@@ -16,7 +16,7 @@ Import-Package: org.eclipse.ecf.core;version="3.0.0",
org.eclipse.ecf.osgi.services.remoteserviceadmin,
org.eclipse.equinox.concurrent.future;version="1.0.0",
org.osgi.framework;version="1.3.0",
+ org.osgi.service.remoteserviceadmin;version="5.0.0",
org.osgi.util.tracker
Bundle-Localization: plugin
-Require-Bundle: org.eclipse.equinox.common;bundle-version="3.6.0",
- org.eclipse.osgi.services.remoteserviceadmin;bundle-version="1.5.0"
+Require-Bundle: org.eclipse.equinox.common;bundle-version="3.6.0"
diff --git a/osgi/bundles/org.eclipse.ecf.osgi.services.remoteserviceadmin/META-INF/MANIFEST.MF b/osgi/bundles/org.eclipse.ecf.osgi.services.remoteserviceadmin/META-INF/MANIFEST.MF
index ea9bc68ea..3478aa72f 100644
--- a/osgi/bundles/org.eclipse.ecf.osgi.services.remoteserviceadmin/META-INF/MANIFEST.MF
+++ b/osgi/bundles/org.eclipse.ecf.osgi.services.remoteserviceadmin/META-INF/MANIFEST.MF
@@ -10,8 +10,7 @@ Bundle-Localization: bundle
Export-Package: org.eclipse.ecf.internal.osgi.services.remoteserviceadmin;x-internal:=true,
org.eclipse.ecf.osgi.services.remoteserviceadmin;version="1.0.0"
Require-Bundle: org.eclipse.equinox.common;bundle-version="3.6.0",
- org.eclipse.ecf.osgi.services.remoteserviceadmin.proxy;bundle-version="1.0.0",
- org.eclipse.osgi.services.remoteserviceadmin
+ org.eclipse.ecf.osgi.services.remoteserviceadmin.proxy;bundle-version="1.0.0"
Bundle-ActivationPolicy: lazy
Import-Package: org.eclipse.ecf.core;version="3.0.0",
org.eclipse.ecf.core.identity,
@@ -27,5 +26,6 @@ Import-Package: org.eclipse.ecf.core;version="3.0.0",
org.osgi.framework.wiring;version="[1.0,2.0)",
org.osgi.service.event,
org.osgi.service.log,
+ org.osgi.service.remoteserviceadmin;version="5.0.0",
org.osgi.util.tracker
DynamicImport-Package: *
diff --git a/osgi/bundles/org.eclipse.osgi.services.remoteserviceadmin/META-INF/MANIFEST.MF b/osgi/bundles/org.eclipse.osgi.services.remoteserviceadmin/META-INF/MANIFEST.MF
index ebc3fa5f5..677a627ff 100644
--- a/osgi/bundles/org.eclipse.osgi.services.remoteserviceadmin/META-INF/MANIFEST.MF
+++ b/osgi/bundles/org.eclipse.osgi.services.remoteserviceadmin/META-INF/MANIFEST.MF
@@ -8,5 +8,5 @@ Bundle-RequiredExecutionEnvironment: J2SE-1.5
Bundle-Localization: bundle
Bundle-Description: %bundle.description
Bundle-Copyright: %bundle.copyright
-Export-Package: org.osgi.service.remoteserviceadmin
+Export-Package: org.osgi.service.remoteserviceadmin;version="5.0.0"
Import-Package: org.osgi.framework
diff --git a/tests/bundles/org.eclipse.ecf.tests.osgi.services.remoteserviceadmin/META-INF/MANIFEST.MF b/tests/bundles/org.eclipse.ecf.tests.osgi.services.remoteserviceadmin/META-INF/MANIFEST.MF
index 674fa2e8a..926cbb1fc 100644
--- a/tests/bundles/org.eclipse.ecf.tests.osgi.services.remoteserviceadmin/META-INF/MANIFEST.MF
+++ b/tests/bundles/org.eclipse.ecf.tests.osgi.services.remoteserviceadmin/META-INF/MANIFEST.MF
@@ -19,9 +19,9 @@ Import-Package: org.eclipse.ecf.core,
org.eclipse.ecf.tests.remoteservice,
org.eclipse.equinox.concurrent.future;version="1.0.0",
org.osgi.framework;version="1.3.0",
+ org.osgi.service.remoteserviceadmin;version="5.0.0",
org.osgi.util.tracker
Require-Bundle: org.eclipse.equinox.common;bundle-version="3.6.0",
org.junit;bundle-version="3.8.0",
- org.eclipse.ecf.tests;bundle-version="2.1.0",
- org.eclipse.osgi.services.remoteserviceadmin;bundle-version="1.5.0"
+ org.eclipse.ecf.tests;bundle-version="2.1.0"
Export-Package: org.eclipse.ecf.tests.osgi.services.remoteserviceadmin;version="1.1.1"

Back to the top