Skip to main content
summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpfullbright2010-08-03 11:57:51 -0400
committerpfullbright2010-08-03 11:57:51 -0400
commitcc74914cdf610c7104c6fa35aaa083702f8c9969 (patch)
tree4c1d28b7c8bd6065bb12befdb5314898ffebf121
parent3393287453a810db4c9c8a5d28c24f16cde5f74e (diff)
downloadwebtools.dali-cc74914cdf610c7104c6fa35aaa083702f8c9969.tar.gz
webtools.dali-cc74914cdf610c7104c6fa35aaa083702f8c9969.tar.xz
webtools.dali-cc74914cdf610c7104c6fa35aaa083702f8c9969.zip
removed module facet requirement and externalized problem marker string
-rw-r--r--jpa/plugins/org.eclipse.jpt.core/plugin.properties1
-rw-r--r--jpa/plugins/org.eclipse.jpt.core/plugin.xml39
2 files changed, 11 insertions, 29 deletions
diff --git a/jpa/plugins/org.eclipse.jpt.core/plugin.properties b/jpa/plugins/org.eclipse.jpt.core/plugin.properties
index 3bbaef82fd..8f3700444b 100644
--- a/jpa/plugins/org.eclipse.jpt.core/plugin.properties
+++ b/jpa/plugins/org.eclipse.jpt.core/plugin.properties
@@ -47,6 +47,7 @@ JPA_1.0_PRESET_LABEL=Minimal JPA 1.0 Configuration
JPA_2.0_PRESET_LABEL=Minimal JPA 2.0 Configuration
JPA_TEMPLATE_LABEL=JPA Project
JPA_VALIDATOR=JPA Validator
+JPA_PROBLEM=JPA Problem
JPA_DELETE_TYPE_PARTICIPANT_NAME=JPA Delete Type Participant
JPA_DELETE_PACKAGE_OR_FOLDER_PARTICIPANT_NAME=JPA Delete Package or Folder Participant
diff --git a/jpa/plugins/org.eclipse.jpt.core/plugin.xml b/jpa/plugins/org.eclipse.jpt.core/plugin.xml
index b66f3ef980..9e2932bb85 100644
--- a/jpa/plugins/org.eclipse.jpt.core/plugin.xml
+++ b/jpa/plugins/org.eclipse.jpt.core/plugin.xml
@@ -435,22 +435,6 @@
</extension>
- <extension
- point="org.eclipse.wst.common.project.facet.core.groups">
-
- <group id="jpa-prereqs">
- <label>%JPA_PREREQ_GROUP_LABEL</label>
- <description>The set of facets that each fulfill JPA prerequisites</description>
- <include facet="jst.utility" versions="[1.0"/>
- <include facet="jst.appclient" versions="[1.2"/>
- <include facet="jst.ejb" versions="[1.1"/>
- <include facet="jst.connector" versions="[1.0"/>
- <include facet="jst.web" versions="[2.2"/>
- </group>
-
- </extension>
-
-
<extension
point="org.eclipse.wst.common.project.facet.core.facets">
@@ -461,19 +445,13 @@
<project-facet-version facet="jpt.jpa" version="1.0">
<constraint>
- <and>
- <requires facet="jst.java" version="[5.0"/>
- <requires group="jpa-prereqs"/>
- </and>
+ <requires facet="jst.java" version="[5.0"/>
</constraint>
</project-facet-version>
<project-facet-version facet="jpt.jpa" version="2.0">
<constraint>
- <and>
- <requires facet="jst.java" version="[5.0"/>
- <requires group="jpa-prereqs"/>
- </and>
+ <requires facet="jst.java" version="[5.0"/>
</constraint>
</project-facet-version>
@@ -573,6 +551,7 @@
</extension>
+
<!-- =================================================================================== -->
<!-- Extension: JPA Problem Marker -->
<!-- **** Do NOT qualify the marker id with org.eclipse.jpt.core, see bug 252891 -->
@@ -580,7 +559,7 @@
<extension
point="org.eclipse.core.resources.markers"
id="jpaProblemMarker"
- name="JPA Problem">
+ name="%JPA_PROBLEM">
<persistent value="true"/>
@@ -592,6 +571,7 @@
<super type="org.eclipse.jdt.core.problem"/>
</extension>
+
<extension
point="org.eclipse.ltk.core.refactoring.deleteParticipants">
@@ -636,9 +616,10 @@
</with>
</enablement>
</deleteParticipant>
- </extension>
-
- <extension
+ </extension>
+
+
+ <extension
point="org.eclipse.ltk.core.refactoring.renameParticipants">
<renameParticipant
class="org.eclipse.jpt.core.internal.refactoring.JpaRenameTypeParticipant"
@@ -687,5 +668,5 @@
</enablement>
</renameParticipant>
</extension>
-
+
</plugin>

Back to the top