summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMat Booth2018-04-10 05:34:28 -0400
committerMat Booth2018-04-10 05:42:07 -0400
commit795496d1ae653954e615db2b20d6c24b61259080 (patch)
tree2a58a70f3544daba1c24a30278eb665b47150047
parentf4cb0a7143d8528ff3e770fe67e59c81a3672dbe (diff)
downloadwebtools.dali-795496d1ae653954e615db2b20d6c24b61259080.tar.gz
webtools.dali-795496d1ae653954e615db2b20d6c24b61259080.tar.xz
webtools.dali-795496d1ae653954e615db2b20d6c24b61259080.zip
[533417] Avoid unnecessary build dependency on javax.xml.bind bundle3.10.03.10.x
This plugin was moved to Java 8 from Java 1.5 in 95df21a and the package "javax.xml.bind" is supplied by the core JRE since Java 6 so there is no longer any need to require it as an extra bundle here in the pom. Signed-off-by: Mat Booth <mat.booth@redhat.com>
-rw-r--r--jaxb/plugins/org.eclipse.jpt.jaxb.core.schemagen/pom.xml22
1 files changed, 1 insertions, 21 deletions
diff --git a/jaxb/plugins/org.eclipse.jpt.jaxb.core.schemagen/pom.xml b/jaxb/plugins/org.eclipse.jpt.jaxb.core.schemagen/pom.xml
index dd82671d5..1674ee2e3 100644
--- a/jaxb/plugins/org.eclipse.jpt.jaxb.core.schemagen/pom.xml
+++ b/jaxb/plugins/org.eclipse.jpt.jaxb.core.schemagen/pom.xml
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<!--
- Copyright (c) 2012, 2013 Eclipse Foundation and others.
+ Copyright (c) 2012, 2018 Eclipse Foundation and others.
All rights reserved. This program and the accompanying materials
are made available under the terms of the Eclipse Distribution License v1.0
which accompanies this distribution, and is available at
@@ -24,24 +24,4 @@
<artifactId>org.eclipse.jpt.jaxb.core.schemagen</artifactId>
<version>1.1.201-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
-
- <build>
- <plugins>
- <plugin>
- <groupId>org.eclipse.tycho</groupId>
- <artifactId>target-platform-configuration</artifactId>
- <configuration>
- <dependency-resolution>
- <extraRequirements>
- <requirement>
- <type>eclipse-plugin</type>
- <id>javax.xml.bind</id>
- <versionRange>0.0.0</versionRange>
- </requirement>
- </extraRequirements>
- </dependency-resolution>
- </configuration>
- </plugin>
- </plugins>
- </build>
</project>