Skip to main content
summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDoug Schaefer2005-11-10 16:41:23 -0500
committerDoug Schaefer2005-11-10 16:41:23 -0500
commitf1fa62b1851de17434e662710a823c85c8678ea8 (patch)
treeb7564efb617f68c435e58332f300807193570fec /releng/org.eclipse.cdt
parenta17df8ba39ad631fb8bdabd39bae389dbe927842 (diff)
downloadorg.eclipse.cdt-f1fa62b1851de17434e662710a823c85c8678ea8.tar.gz
org.eclipse.cdt-f1fa62b1851de17434e662710a823c85c8678ea8.tar.xz
org.eclipse.cdt-f1fa62b1851de17434e662710a823c85c8678ea8.zip
Upversioned everything. Changed the features to not unpack the plugins that don't have shared libraries.
Diffstat (limited to 'releng/org.eclipse.cdt')
-rw-r--r--releng/org.eclipse.cdt/META-INF/MANIFEST.MF10
-rw-r--r--releng/org.eclipse.cdt/build.properties3
-rw-r--r--releng/org.eclipse.cdt/plugin.xml15
3 files changed, 14 insertions, 14 deletions
diff --git a/releng/org.eclipse.cdt/META-INF/MANIFEST.MF b/releng/org.eclipse.cdt/META-INF/MANIFEST.MF
new file mode 100644
index 0000000000..bd6c43b2e6
--- /dev/null
+++ b/releng/org.eclipse.cdt/META-INF/MANIFEST.MF
@@ -0,0 +1,10 @@
+Manifest-Version: 1.0
+Bundle-ManifestVersion: 2
+Bundle-Name: %pluginName
+Bundle-SymbolicName: org.eclipse.cdt; singleton:=true
+Bundle-Version: 3.1.0
+Bundle-Vendor: %providerName
+Bundle-Localization: plugin
+Require-Bundle: org.eclipse.ui.intro,
+ org.eclipse.ui.cheatsheets
+Eclipse-AutoStart: true
diff --git a/releng/org.eclipse.cdt/build.properties b/releng/org.eclipse.cdt/build.properties
index f5b46b997f..b973f6fc9e 100644
--- a/releng/org.eclipse.cdt/build.properties
+++ b/releng/org.eclipse.cdt/build.properties
@@ -17,4 +17,5 @@ bin.includes = about.html,\
plugin.properties,\
plugin.xml,\
css/,\
- intro/
+ intro/,\
+ META-INF/
diff --git a/releng/org.eclipse.cdt/plugin.xml b/releng/org.eclipse.cdt/plugin.xml
index 08203d1e10..f20738b7c9 100644
--- a/releng/org.eclipse.cdt/plugin.xml
+++ b/releng/org.eclipse.cdt/plugin.xml
@@ -1,15 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<?eclipse version="3.0"?>
-<plugin
- id="org.eclipse.cdt"
- name="%pluginName"
- version="3.0.0"
- provider-name="%providerName">
- <requires>
- <import plugin="org.eclipse.ui.intro"/>
- <import plugin="org.eclipse.ui.cheatsheets"/>
- </requires>
-
+<plugin>
<extension
point="org.eclipse.ui.intro.configExtension">
<configExtension
@@ -39,7 +30,5 @@
</cheatsheet>
</extension-->
- <runtime>
- </runtime>
-
+
</plugin>

Back to the top