Skip to main content
summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonah Graham2017-02-21 04:43:22 -0500
committerGerrit Code Review @ Eclipse.org2017-02-21 09:43:44 -0500
commit3c2b9044887058f0a6446c8c107f340067fb8615 (patch)
tree8c2e2df1dfc3b1eae3500f6be6bfda2c63ea4d23
parent848b4c4bae7b7d50648ce05e7f329c4e35dda156 (diff)
downloadorg.eclipse.cdt-3c2b9044887058f0a6446c8c107f340067fb8615.tar.gz
org.eclipse.cdt-3c2b9044887058f0a6446c8c107f340067fb8615.tar.xz
org.eclipse.cdt-3c2b9044887058f0a6446c8c107f340067fb8615.zip
Bug 509320: Revert update to re-exported version
This is a partial revert of e49517eb7c9ceb0a35581c96685a27eabf2ccdd8. This revert prevents an otherwise unnecessary API version increment. As e49517e added the correct version dependency from org.eclipse.cdt.dsf.gdb to org.eclipse.cdt.core.native, which was the true dependency, we don't have to increase the dependency on the re-exported version within org.eclipse.cdt.core. Because org.eclipse.cdt.core.native is a singleton and only the 5.10 version of org.eclipse.cdt.core.native will satisfy the dependency where it is needed in dsf-gdb, this solution guarantees correct wiring up. Change-Id: I23b32480550fee33a4e156a91df12ac7720d8dc3 Signed-off-by: Jonah Graham <jonah@kichwacoders.com>
-rw-r--r--core/org.eclipse.cdt.core/META-INF/MANIFEST.MF2
1 files changed, 1 insertions, 1 deletions
diff --git a/core/org.eclipse.cdt.core/META-INF/MANIFEST.MF b/core/org.eclipse.cdt.core/META-INF/MANIFEST.MF
index 317d693eba..cfd08eca52 100644
--- a/core/org.eclipse.cdt.core/META-INF/MANIFEST.MF
+++ b/core/org.eclipse.cdt.core/META-INF/MANIFEST.MF
@@ -117,7 +117,7 @@ Export-Package: org.eclipse.cdt.core,
org.eclipse.cdt.utils.som.parser,
org.eclipse.cdt.utils.xcoff,
org.eclipse.cdt.utils.xcoff.parser
-Require-Bundle: org.eclipse.cdt.core.native;bundle-version="[5.10.0,6.0.0)";visibility:=reexport,
+Require-Bundle: org.eclipse.cdt.core.native;bundle-version="[5.7.0,6.0.0)";visibility:=reexport,
org.eclipse.core.contenttype;bundle-version="[3.3.0,4.0.0)",
org.eclipse.core.expressions;bundle-version="[3.2.0,4.0.0)",
org.eclipse.core.filebuffers;bundle-version="[3.2.0,4.0.0)",

Back to the top