summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEike Stepper2008-05-27 08:40:40 (EDT)
committerEike Stepper2008-05-27 08:40:40 (EDT)
commit26134232ff5596f21293e511ebffe670c5bc6771 (patch)
tree0ced462a2b5471d93ccd7da270700a2ef1e31ef3
parent3294556ad7aaa05d2647bafe5ea78b88ab6c389f (diff)
downloadcdo-26134232ff5596f21293e511ebffe670c5bc6771.zip
cdo-26134232ff5596f21293e511ebffe670c5bc6771.tar.gz
cdo-26134232ff5596f21293e511ebffe670c5bc6771.tar.bz2
[234041] Prepare graduation
https://bugs.eclipse.org/bugs/show_bug.cgi?id=234041
-rw-r--r--features/org.eclipse.net4j.db-feature/feature.xml7
-rw-r--r--plugins/org.eclipse.net4j.db.derby/.classpath2
-rw-r--r--plugins/org.eclipse.net4j.db.derby/META-INF/MANIFEST.MF91
-rw-r--r--plugins/org.eclipse.net4j.db.derby/build.properties3
-rw-r--r--plugins/org.eclipse.net4j.db.derby/plugin.xml4
5 files changed, 12 insertions, 95 deletions
diff --git a/features/org.eclipse.net4j.db-feature/feature.xml b/features/org.eclipse.net4j.db-feature/feature.xml
index 1ee20d9..0d54fd4 100644
--- a/features/org.eclipse.net4j.db-feature/feature.xml
+++ b/features/org.eclipse.net4j.db-feature/feature.xml
@@ -60,4 +60,11 @@
install-size="0"
version="0.0.0"/>
+ <plugin
+ id="org.apache.derby"
+ download-size="0"
+ install-size="0"
+ version="0.0.0"
+ unpack="false"/>
+
</feature>
diff --git a/plugins/org.eclipse.net4j.db.derby/.classpath b/plugins/org.eclipse.net4j.db.derby/.classpath
index 8f73863..64c5e31 100644
--- a/plugins/org.eclipse.net4j.db.derby/.classpath
+++ b/plugins/org.eclipse.net4j.db.derby/.classpath
@@ -3,7 +3,5 @@
<classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
- <classpathentry exported="true" kind="lib" path="lib/derby.jar" sourcepath="org.eclipse.net4j.db.derbysrc.zip"/>
- <classpathentry exported="true" kind="lib" path="lib/derbyclient.jar" sourcepath="org.eclipse.net4j.db.derbysrc.zip"/>
<classpathentry kind="output" path="bin"/>
</classpath>
diff --git a/plugins/org.eclipse.net4j.db.derby/META-INF/MANIFEST.MF b/plugins/org.eclipse.net4j.db.derby/META-INF/MANIFEST.MF
index a010e5b..5a45290 100644
--- a/plugins/org.eclipse.net4j.db.derby/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.net4j.db.derby/META-INF/MANIFEST.MF
@@ -6,95 +6,8 @@ Bundle-Version: 1.0.0.qualifier
Bundle-Vendor: %providerName
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Bundle-ClassPath: .,
- lib/derby.jar,
- lib/derbyclient.jar
+Bundle-ClassPath: .
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.4.0,4.0.0)",
org.eclipse.net4j.db;bundle-version="[1.0.0,2.0.0)";visibility:=reexport
-Export-Package: org.apache.derby.authentication;version="10.3.2",
- org.apache.derby.catalog;version="10.3.2",
- org.apache.derby.catalog.types;version="10.3.2",
- org.apache.derby.client;version="10.3.2",
- org.apache.derby.client.am;version="10.3.2",
- org.apache.derby.client.net;version="10.3.2",
- org.apache.derby.database;version="10.3.2",
- org.apache.derby.diag;version="10.3.2",
- org.apache.derby.iapi.db;version="10.3.2",
- org.apache.derby.iapi.error;version="10.3.2",
- org.apache.derby.iapi.jdbc;version="10.3.2",
- org.apache.derby.iapi.services.cache;version="10.3.2",
- org.apache.derby.iapi.services.classfile;version="10.3.2",
- org.apache.derby.iapi.services.compiler;version="10.3.2",
- org.apache.derby.iapi.services.context;version="10.3.2",
- org.apache.derby.iapi.services.crypto;version="10.3.2",
- org.apache.derby.iapi.services.daemon;version="10.3.2",
- org.apache.derby.iapi.services.diag;version="10.3.2",
- org.apache.derby.iapi.services.i18n;version="10.3.2",
- org.apache.derby.iapi.services.info;version="10.3.2",
- org.apache.derby.iapi.services.io;version="10.3.2",
- org.apache.derby.iapi.services.loader;version="10.3.2",
- org.apache.derby.iapi.services.locks;version="10.3.2",
- org.apache.derby.iapi.services.memory;version="10.3.2",
- org.apache.derby.iapi.services.monitor;version="10.3.2",
- org.apache.derby.iapi.services.property;version="10.3.2",
- org.apache.derby.iapi.services.stream;version="10.3.2",
- org.apache.derby.iapi.services.timer;version="10.3.2",
- org.apache.derby.iapi.services.uuid;version="10.3.2",
- org.apache.derby.iapi.sql;version="10.3.2",
- org.apache.derby.iapi.sql.compile;version="10.3.2",
- org.apache.derby.iapi.sql.conn;version="10.3.2",
- org.apache.derby.iapi.sql.depend;version="10.3.2",
- org.apache.derby.iapi.sql.dictionary;version="10.3.2",
- org.apache.derby.iapi.sql.execute;version="10.3.2",
- org.apache.derby.iapi.store.access;version="10.3.2",
- org.apache.derby.iapi.store.access.conglomerate;version="10.3.2",
- org.apache.derby.iapi.store.access.xa;version="10.3.2",
- org.apache.derby.iapi.store.raw;version="10.3.2",
- org.apache.derby.iapi.store.raw.data;version="10.3.2",
- org.apache.derby.iapi.store.raw.log;version="10.3.2",
- org.apache.derby.iapi.store.raw.xact;version="10.3.2",
- org.apache.derby.iapi.tools.i18n;version="10.3.2",
- org.apache.derby.iapi.types;version="10.3.2",
- org.apache.derby.iapi.util;version="10.3.2",
- org.apache.derby.impl.db;version="10.3.2",
- org.apache.derby.impl.io;version="10.3.2",
- org.apache.derby.impl.jdbc;version="10.3.2",
- org.apache.derby.impl.jdbc.authentication;version="10.3.2",
- org.apache.derby.impl.load;version="10.3.2",
- org.apache.derby.impl.services.bytecode;version="10.3.2",
- org.apache.derby.impl.services.cache;version="10.3.2",
- org.apache.derby.impl.services.daemon;version="10.3.2",
- org.apache.derby.impl.services.jce;version="10.3.2",
- org.apache.derby.impl.services.locks;version="10.3.2",
- org.apache.derby.impl.services.monitor;version="10.3.2",
- org.apache.derby.impl.services.reflect;version="10.3.2",
- org.apache.derby.impl.services.stream;version="10.3.2",
- org.apache.derby.impl.services.timer;version="10.3.2",
- org.apache.derby.impl.services.uuid;version="10.3.2",
- org.apache.derby.impl.sql;version="10.3.2",
- org.apache.derby.impl.sql.catalog;version="10.3.2",
- org.apache.derby.impl.sql.compile;version="10.3.2",
- org.apache.derby.impl.sql.conn;version="10.3.2",
- org.apache.derby.impl.sql.depend;version="10.3.2",
- org.apache.derby.impl.sql.execute;version="10.3.2",
- org.apache.derby.impl.sql.execute.rts;version="10.3.2",
- org.apache.derby.impl.store.access;version="10.3.2",
- org.apache.derby.impl.store.access.btree;version="10.3.2",
- org.apache.derby.impl.store.access.btree.index;version="10.3.2",
- org.apache.derby.impl.store.access.conglomerate;version="10.3.2",
- org.apache.derby.impl.store.access.heap;version="10.3.2",
- org.apache.derby.impl.store.access.sort;version="10.3.2",
- org.apache.derby.impl.store.raw;version="10.3.2",
- org.apache.derby.impl.store.raw.data;version="10.3.2",
- org.apache.derby.impl.store.raw.log;version="10.3.2",
- org.apache.derby.impl.store.raw.xact;version="10.3.2",
- org.apache.derby.impl.tools.sysinfo;version="10.3.2",
- org.apache.derby.io;version="10.3.2",
- org.apache.derby.jdbc;version="10.3.2",
- org.apache.derby.osgi;version="10.3.2",
- org.apache.derby.shared.common.error;version="10.3.2",
- org.apache.derby.shared.common.i18n;version="10.3.2",
- org.apache.derby.tools;version="10.3.2",
- org.apache.derby.vti;version="10.3.2",
- org.eclipse.net4j.db.internal.derby;version="1.0.0"
+Export-Package: org.eclipse.net4j.db.internal.derby;version="1.0.0"
Eclipse-RegisterBuddy: org.eclipse.net4j.db
diff --git a/plugins/org.eclipse.net4j.db.derby/build.properties b/plugins/org.eclipse.net4j.db.derby/build.properties
index 52384b7..73c6cce 100644
--- a/plugins/org.eclipse.net4j.db.derby/build.properties
+++ b/plugins/org.eclipse.net4j.db.derby/build.properties
@@ -19,5 +19,4 @@ bin.includes = META-INF/,\
epl-v10.html,\
license.html,\
plugin.properties,\
- plugin.xml,\
- lib/
+ plugin.xml
diff --git a/plugins/org.eclipse.net4j.db.derby/plugin.xml b/plugins/org.eclipse.net4j.db.derby/plugin.xml
index a9e4895..fd333b1 100644
--- a/plugins/org.eclipse.net4j.db.derby/plugin.xml
+++ b/plugins/org.eclipse.net4j.db.derby/plugin.xml
@@ -22,11 +22,11 @@
<dbAdapter
class="org.eclipse.net4j.db.internal.derby.EmbeddedDerbyAdapter"
name="derby-embedded"
- version="10.3.2.1"/>
+ version="10.3.1.4"/>
<dbAdapter
class="org.eclipse.net4j.db.internal.derby.ClientDerbyAdapter"
name="derby-client"
- version="10.3.2.1"/>
+ version="10.3.1.4"/>
</extension>
</plugin>